Go Back   Grim Dawn Forums > Grim Dawn Gameplay > Bug Reporting

Reply
Click here to go to the first staff post in this thread.  
Thread Tools Display Modes
  #1  
Old 06-20-2018, 06:12 PM
Justice Knight Justice Knight is offline
Initiate
 
Join Date: Jun 2018
Posts: 1
Default Grim Dawn stuck at 60hz in Full Screen only

=========
i7 2600k
Nvidia GTX 1080 FE
Windows 10
144hz monitor
GD 1.0.6.1
=========

Issue :

When I started playing the first time, game ran great at 144hz in full screen and now it's it's stuck at 60fps/hz.

Background:
I have a 144hz monitor and when I first loaded Grim Dawn, the game settings were using full screen mode and in the resolution drop down I had all of the varied hz options such as 59,60, 144hz etc. per each resolution.

It defaulted to my native resolution and maximum hz and it played ok for several hours.


Then the next time I ran the client, the game was feeling odd, kinda warpy and laggy. I noticed that the frame latency was bouncing up and down consistently despite the frame rate being pegged at 144, it was going from 7ms to 14ms like a yoyo.


Then it proceeded to get worse. The game was stuck on 60fps unless I turned off Vsync. The game would return to 144fps however the latency issue was there again.


I reloaded the graphics driver in Windows(not reinstalled, Winkey Shift Ctrl B reloads driver) and that was unhelpful as well.

Then I restarted the game again and this time in the resolution menu I noticed, all the hz options above 60 were removed completely. Instead of 2560x1440@ 40, 59, 60, 144hz etc. It was just 2560x1440@60hz

After doing some search around the net, I found you could manually amend the graphics file in the GD settings. I did this and upon loading the game the resolution menu had one entry with my manual/custom(?) hz. i.e. 2560x1440@144hz
Though curious, it only applied at my current native resolution where as the first time I ran the game, it showed for all capable resolutions as mentioned prior.

Loading into the game world, the same problem existed and yet now even worse, removing Vsync would not let the client go over 60fps/60hz where as before it would.

I (by accident) changed it to Windowed mode moments later and it shot back up to maxium frames, even with Vsync enabled.

However toggling back to Fullscreen, it went down to 60 again.



I also removed the options.txt to let it create a new one and the issue persists.

SOMETIMES a reboot works, and others it happens even on my first attempt from starting Windows.

Current Workaround :

Running the client in windowed mode (switching to windowed borderless sends it back to a capped 60fps/60hz).

Summary :
It worked the first time, now 9/10 on a fresh start up of the system, Grim Dawn will not play above 60hz/60fps in Full Screen with or without Vsync enabled, even while the resolution states and the options file state it's using 2560x1440@144hz

Last edited by Justice Knight; 06-20-2018 at 06:15 PM.
Reply With Quote
  This is the last staff post in this thread.   #2  
Old 06-20-2018, 06:18 PM
Zantai's Avatar
Zantai Zantai is offline
Crate Employee - Designer
 
Join Date: May 2012
Posts: 7,411
Default

Resolution/refresh rate settings the game displays are controlled by Windows/your video card's control panel, so I'd check there to see if those are still set correctly.
__________________
***Waste of Souls***
Reply With Quote
Reply

Tags
144hz, full, fullscreen, screen, vsync

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Grim Dawn ©2018 Crate Entertainment, LLC.
vBulletin® 3.8.4 ©2000-2014, Jelsoft Enterprises Ltd.