Go Back   Grim Dawn Forums > Grim Dawn Community Section > Modding - Tutorials and Help

Reply
 
Thread Tools Display Modes
  #1  
Old 09-10-2018, 12:43 AM
Ahrimat Ahrimat is offline
Initiate
 
Join Date: Sep 2018
Posts: 1
Default Terrain not rendering in Editor.exe - Extraction error?

First off, Grim Dawn is amazing! I'm ready to sink some heavy hours into this gem. Not really how it slipped under my radar until 2018. Anyhow, I just put in about 28 hours into this game and now I'm curious about modding it.

I've followed all the guides on this forum and watched a couple videos on YouTube. So I'm pretty confident I have not missed a step on any of these "Getting Started" guides, yet every outcome is the same when I try to start working on level terrain: I don't see a damn thing.

After making a mod, extracting the files into a Working directory, doing an initial build, closing Asset Manager before opening the Editor etc. etc., I do not see anything under the source tree within the opening dialogue. At first I didn't think anything of it. I'll just create a new world and go to town, no big deal right?

After plopping down some level zones in the Layout mode and switching over to Editor mode, I don't see anything. Just a black void and a red outline of the zone if I zoom out a tad. Everything is empty. I can't even find objects listed anywhere ready to be placed.

I've tried starting the process over several times using Admin rights in Windows and even reinstalling the game twice. Same result every time. The way materials and assets seem to not exist makes me wonder if anything extracted properly. File Explorer shows everything is there and taking up space, but it's as if Editor.exe can't find it. Has anyone else had this issue or am I doing something wrong somehow? Any insight is appreciated! These tools were a pleasant surprise when I bought the game on a whim; they are obviously pretty powerful and it's giving me the content creation itch once again, one that I'd really love to scratch!
Reply With Quote
  #2  
Old 09-11-2018, 12:08 AM
ASYLUM101's Avatar
ASYLUM101 ASYLUM101 is offline
Praetorian
 
Join Date: Jan 2010
Posts: 8,303
Default

I remember someone else had a problem like this, I don't think they ever fixed it. : /

Best option atm for people to help is to post your info in the AssetManager options screen, these directories are important for managing the other tools iirc.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Grim Dawn ©2018 Crate Entertainment, LLC.
vBulletin® 3.8.4 ©2000-2014, Jelsoft Enterprises Ltd.