#1  
Old 03-11-2018, 12:32 PM
Darkstalix's Avatar
Darkstalix Darkstalix is offline
Counsel
 
Join Date: Oct 2016
Posts: 296
Default DX11 vs DX9 or my hardware issues?

This is very confusing for me cause since i moved to w10 and to dx11 i started seeing some differences
I don't know why this happens tho?Maybe its the API's way of outputting this or its with the game itself?
I know that the dx11 is way more stable in game and i don't get so many crashes but these pics below will explain my issue
Both screenshots are in the same video options and in the same place one on dx11 and one with the /d3d9 launch command line.

This happens when you have disabled the anti-aliasing.
I had to make the screens in the same place of the map so they are exactly the same and see the difference, and sorry for the big screenies.

Click to see the exact problem
This is with the dx11


And this is with dx9


In other words in dx9 it "looks" visually better on my hardware,maybe gfx prob? And its not that this happens only with the leavs but almost anything with small textures even their shadows
Anyone has any idea why this is happening?
Reply With Quote
  #2  
Old 03-11-2018, 01:38 PM
Jaknet's Avatar
Jaknet Jaknet is offline
Praetorian
 
Join Date: May 2013
Posts: 4,503
Default

Maybe try disabling the Ambient Occlusion which was added when the dx11 was introduced...shrug. Sorry not more help here
Reply With Quote
  #3  
Old 03-11-2018, 01:45 PM
Darkstalix's Avatar
Darkstalix Darkstalix is offline
Counsel
 
Join Date: Oct 2016
Posts: 296
Default

Quote:
Originally Posted by Jaknet View Post
Maybe try disabling the Ambient Occlusion which was added when the dx11 was introduced...shrug. Sorry not more help here
I tried everything :/ it only goes away if i get antialiasing from x4 and further
Everything before this its the same. Tha bad thing that this happens only on DX11

thanks anw tho
Reply With Quote
  #4  
Old 03-11-2018, 02:52 PM
lqdhorror's Avatar
lqdhorror lqdhorror is offline
Supporter
 
Join Date: Oct 2014
Posts: 184
Default

Could be the way DX11 handles the "Alpha to Coverage" settings.

Try toggling that off and on to see if that changes anything.

I've never seen this myself or maybe I never noticed....

Maybe, just maybe, it's a driver issue on your end.

Do a clean DDU uninstall of your current drivers, then install the latest ver etc.
__________________
i5-750 Lynnfield @ 3.6 GHz | ASUS Strix 960 4GB @ 1450/7600 | 16GB Crucial DDR3 | Asus Xonar DG | GA-P55A-UD3 | Samsung 840 Pro 256GB |
WD Elements 3TB | EVGA SuperNOVA G2 650W | Win7 64
Reply With Quote
  #5  
Old 03-11-2018, 03:09 PM
Jaknet's Avatar
Jaknet Jaknet is offline
Praetorian
 
Join Date: May 2013
Posts: 4,503
Default

Quote:
Originally Posted by Darkstalix View Post
This happens when you have disabled the anti-aliasing.
Quote:
Originally Posted by Darkstalix View Post
it only goes away if i get antialiasing from x4 and further
Just occurred to me, why do you not simply run with the AA on and turned up as surely the point of AA is to give you an improved image and try to hide the fact that a computer cannot draw a curve.. ?? I run with max AA all the time in dx11 and I'm wondering why you are running with it turned off, just genuinely curious
Reply With Quote
  #6  
Old 03-11-2018, 03:28 PM
Darkstalix's Avatar
Darkstalix Darkstalix is offline
Counsel
 
Join Date: Oct 2016
Posts: 296
Default

Quote:
Originally Posted by lqdhorror View Post
Could be the way DX11 handles the "Alpha to Coverage" settings.
Try toggling that off and on to see if that changes anything.
I've never seen this myself or maybe I never noticed....
Maybe, just maybe, it's a driver issue on your end.
Do a clean DDU uninstall of your current drivers, then install the latest ver etc.
I did that like a week ago and installed the latest as always..
But the issue was visible till i started using dx11 :/

Quote:
Originally Posted by Jaknet View Post
Just occurred to me, why do you not simply run with the AA on and turned up as surely the point of AA is to give you an improved image and try to hide the fact that a computer cannot draw a curve.. ?? I run with max AA all the time in dx11 and I'm wondering why you are running with it turned off, just genuinely curious
I mostly play MP games and AA drops the framerates a lot with so many things on screen and thats why i go without AA. Its not like my pc is a beast xD

Last edited by Darkstalix; 03-11-2018 at 03:30 PM.
Reply With Quote
  #7  
Old 03-11-2018, 03:32 PM
Jaknet's Avatar
Jaknet Jaknet is offline
Praetorian
 
Join Date: May 2013
Posts: 4,503
Default

Ah ha... fully understand now. Cheers
Reply With Quote
  #8  
Old 03-11-2018, 03:35 PM
Darkstalix's Avatar
Darkstalix Darkstalix is offline
Counsel
 
Join Date: Oct 2016
Posts: 296
Default

Quote:
Originally Posted by lqdhorror View Post
Could be the way DX11 handles the "Alpha to Coverage" settings.

Ok got it, it was actually that. Why that happens i got no idea tho ._.
thanks for the suggestions peeps
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Grim Dawn ©2018 Crate Entertainment, LLC.
vBulletin® 3.8.4 ©2000-2014, Jelsoft Enterprises Ltd.